Direct Debits Processing Delay For T+3 NAB Merchants - 10/08/2023
Incident Report for Fat Zebra Status Page
Resolved
NAB have now confirmed the direct debits have been processed.
Posted Aug 11, 2023 - 17:36 AEST
Investigating
There has been a delay in processing direct debits with a processing date of the 10/08/2023 for merchants using our T+3 NAB facility.

These direct debits should have been processed at 5pm AEST yesterday afternoon, however, due to an issue on NAB's end they have been delayed.

NAB are currently investigating the issue from their end, as a better of urgency.

We will provide further update as soon as possible.
Posted Aug 11, 2023 - 16:14 AEST